ZOJ3498-Javabeans


I - Javabeans
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  ZOJ 3498

Description

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

Each test case is a line of a positive integer 0 < n < 231.

Output

For each test case output the result in a single line.

Sample Input

4
1
2
3
4

Sample Output

1
2
2
3

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int t, n;
    cin >> t;
    while(t--)
    {
        int sum=0;
        scanf("%d",&n);
        while(n>0)
        {
            n/=2;
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

你可能感兴趣的:(ZOJ3498-Javabeans)