HDOJ 5366 The mook jong(规律)

The mook jong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 686    Accepted Submission(s): 475


Problem Description
![](../../data/images/C613-1001-1.jpg)

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).
 

Input
There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)
 

Output
Print the ways in a single line for each case.
 

Sample Input
   
   
   
   
1 2 3 4 5 6
 

Sample Output
   
   
   
   
1 2 3 5 8 12
我是列出来一些数据,然后试着找规律
ans[i]=ans[i-1]+ans[i-3]+1

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 2555
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
long long ans[MAXN];//这里long long wa了一发
void db()
{
	ans[1]=1;
	ans[2]=2;
	ans[3]=3;
	for(int i=4;i<=60;i++)
	ans[i]=ans[i-1]+ans[i-3]+1;
}
int main()
{
	db();
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%lld\n",ans[n]);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 5366 The mook jong(规律))