HDOJ 2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14594    Accepted Submission(s): 6514


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
   
   
   
   
2 100 -4
 

Sample Output
   
   
   
   
1.6152 No solution!
 
此问题真的不难,奈何我道行太低,花了好久的时间才根据别人的代码AC,对二分掌握不太牢固啊!
这个问题直接二分到底就行,不需要找到时break
代码如下:
#include<cstdio>
#include<cmath>
#define zero 1e-8
double Sum(double x)//求出所给公式的结果
{
     return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    int t;
    double n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&n);
        if(n>=Sum(0)&&n<=Sum(100))
        {
            double low=0,high=100.0,mid;
            while(high-low>zero)
            {
                mid=(high+low)/2;
                if(Sum(mid)-n>1e-20)
                    high=mid;
               else if(Sum(mid)-n<=1e-20)
                   low=mid;
             }
             printf("%.4lf\n",low);
        }
        else
            printf("No solution!\n");
    }
}

你可能感兴趣的:(二分查找,杭电)