题目编号:1006
简单题意:The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2
3 2 3 1
0
Sample Output
17
41
解题思路:用一个数组把数据存起来,这样计算时间时只要比较上一个数据和下一个数据就可以知道如何处理时间的变化。需要特别注意的就是Ground Floor是英式英语中的0层,也就是说如果输入的数据为1 1,仍然需要考虑0到1 的过程,从而结果为11秒。
AC代码:
#include<iostream>
using namespace std;
int main()
{
int n;
int a[100];
int ans;
while(cin>>n&&n!=0){
a[0]=0;
ans=0;
for(int i=1;i<=n;i++){
cin>>a[i];}
for(int j=1;j<=n;j++)
{
if(a[j]>a[j-1]) ans=ans+(a[j]-a[j-1])* 6+5;
else ans=ans+(a[j-1]-a[j])*4+5;
}
cout<<ans<<endl;
}
return 0;
}
感悟:这题其实还是相对而言比较简单的。我做题的时候主要的矛盾点在0层——ground floor;总得来说还是不要转牛角尖。