Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14268 Accepted Submission(s): 8845
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
…@…
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
这个题是最简单的DFS题,下面是解题思路:
1.首先弄清楚题目,题目要求找出从起点开始可以到达的最大范围,没有绕弯直接使用DFS实现。
2.注意在最外层加上套,防止搜索越界!
具体代码如下:
#include <stdio.h>
#include <string.h>
const int N=50;
int map[N][N];
int vis[N][N];
int count=0;
void DFS(int x,int y)
{
if(map[x][y]=='#'||map[x][y]==0||vis[x][y]==1)
return ;
vis[x][y]=1;
count++;
DFS(x+1,y);
DFS(x-1,y);
DFS(x,y+1);
DFS(x,y-1);
}
int main()
{
int m,n;
char s[N];
while (scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
return 0;
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i=0;i<m;i++)
{
scanf("%s",s);
for(int j=0;j<n;j++)
{
map[i+1][j+1]=s[j];
}
}
for(int i=1;i<=m;i++)
{
for(int j=1;j<=n;j++)
{
if(map[i][j]=='@')
{
DFS(i,j);
}
}
}
printf("%d\n",count);
count=0;
}
return 0;
}
仅代表个人观点,不喜勿喷,欢迎交流!!!