HDU 1520 Anniversary party 树形DP入门

题目描述:

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题目分析:

这道题的大意是有n个点,每个点有一个权,其中有数条边,问在这n个点中取若干点,求最大权值是多少。(其中如果选了点i,其直接的父节点不能选)
树形DP经典题。刚开始做的时候我想着不建树了,果然不行。
状态转移方程很好理解

dp[u][0]+=max(dp[v][0],dp[v][1]);
dp[u][1]+=dp[v][0];

选u用dp[u][1]表示,加上不选其子节点的方案数。
不选u用dp[u][0]表示,加上其选子节点或者不选子节点最大的方案数。

代码如下:

TLE代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#define MAXN 6005
using namespace std;


int n;
int father[MAXN];
bool visit[MAXN];
int dp[MAXN][2];
void DP(int cur)
{
    visit[cur]=1;
    for(int i=1; i<=n; i++)
    {
        if (!visit[i] && father[i]==cur)
        {
            DP(i);
            dp[cur][1]+=dp[i][0];
            dp[cur][0]+=max(dp[i][1],dp[i][0]);
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        memset(father,0,sizeof(father));
        memset(visit,0,sizeof(visit));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);
        }
        int root=0;
        int u,v;
        while(~scanf("%d%d",&u,&v) && (u||v)) {father[u]=v; root=v;}
        while(father[root]) root=father[root];
        DP(root);
        int ans=max(dp[root][0],dp[root][1]);
        printf("%d\n",ans);
    }
    return 0;
}

AC代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#define MAXN 6005
using namespace std;

int n;
int father[MAXN];
bool visit[MAXN];
int val[MAXN];
int dp[MAXN][2];
int ans;

struct sa
{
    int v;
    int next;
}tree[MAXN<<1];

int head[MAXN],e;
void init()
{
    e=0;
    memset(head,-1,sizeof(head));
}

void addedge(int u,int v)
{
    tree[e].v=v;
    tree[e].next=head[u];
    head[u]=e++;
}

int dfs(int u)
{
    visit[u]=1;
    dp[u][0]=0;
    dp[u][1]=val[u];
    for (int i=head[u]; i!=-1; i=tree[i].next)
    {
        int v = tree[i].v;
        dfs(v);
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        dp[u][1]+=dp[v][0];
    }
    return max(dp[u][0],dp[u][1]);
}

int main()
{
    while(~scanf("%d",&n))
    {
        init();
        memset(dp,0,sizeof(dp));
        memset(father,0,sizeof(father));
        memset(visit,0,sizeof(visit));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&val[i]);
        }
        int u,v;
        while(~scanf("%d%d",&v,&u) && (u||v))
        {
            addedge(u,v);
            father[v]++;
        }
        ans=0;
        for(int i=1; i<=n; i++)
        {
            if (!father[i]) ans+=dfs(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(dp)