hdu2602Bone Collector(01背包)

Bone Collector

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdu2602Bone Collector(01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest

    题意:

    有5个物品   背包容量就是10

   体积     5    4   3   2    1

   价值     1    2   3   4    5

   #include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[10000],b[10000];
int dp[10000];
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
       int m,v,i,j;
       scanf("%d%d",&m,&v);
       for(i=0;i<m;i++)
           scanf("%d",&a[i]);
       for(i=0;i<m;i++)
           scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
        for(i=0;i<m;i++)//01背包的模板
        {
            for(j=v;j>=b[i];j--)
            {
                dp[j]=max(dp[j-b[i]]+a[i],dp[j]);
            }
        }
    
        printf("%d\n",dp[v]);
    }


    return 0;
}

你可能感兴趣的:(动态规划,01背包)