POJ - 3673 Cow Multiplication

POJ - 3673

Cow Multiplication

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B.

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54

Source

USACO 2008 February Bronze


/*
    Coder: Shawn_Xue
    Date: 2015.3.28
    Result: AC
    Description: POJ-3673  Cow Multiplication
*/
#include <iostream>

using namespace std;

int main()
{
    int a, b;

    while(cin >> a >> b)
    {
        int sum = 0;
        int tmp1 = 0, tmp2 = 0;
        while(a)
        {
            tmp1 = a % 10;
            int t = b;  //  把b保存起来
            while(t)
            {
                tmp2 = t % 10;
                sum = sum + tmp1*tmp2;
                t = t / 10;
            }
            a = a / 10;
        }
        cout << sum << endl;
    }
}



你可能感兴趣的:(POJ - 3673 Cow Multiplication)