PAT-PAT (Advanced Level) Practise 1031. Hello World for U (20) (图形打印) 【二星级】

题目链接:http://www.patest.cn/contests/pat-a-practise/1031


题面:

1031. Hello World for U (20)


Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor


题目大意:

    要求打印成u字形,且要让两边尽量长,但要小于等于底边长。


解题:

    简单推导一下,可以发现,底边最多比两边长2,大于等于3的话,可以往两边挪。注意输出,推一下下标就好。


代码:

#include <cstdio>
#include <vector>
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
    string s;
	cin>>s;
	int len=s.length(),a,b,c;
    a=(len+2)/3;//两边长
    b=(len+2)%3;//底边比两边长的长度
	//数清楚个数,即可
	for(int i=1;i<a;i++)
	{
		printf("%c",s[i-1]);
		for(int j=0;j<(a+b-2);j++)
			printf(" ");
		printf("%c",s[len-i]);
		printf("\n");
	}
	c=a-1;
	//最后一行
	for(int i=0;i<(a+b);i++)
		printf("%c",s[c++]);
	printf("\n");
	return 0;
}


你可能感兴趣的:(图形,水题,pat)