2016西电校赛网络赛 Problem E 删除字符

Problem E

问题描述

万神需要生成两个串 a、b,使得 a 不包含任何在 b 中出现过的字符。现在
万神已经有两个串 A、B,他希望令 b = B,然后将所有在 b 中出现过的字符从
A 中删掉,以得到 a。

输入格式

输入包含多组数据(至多 100 组),请处理到文件结束。
每组数据只有 1 行,包含串 A、B,用空格分割。
保证 A、B 只包含小写字母,且 1 ≤ |A|, |B| ≤ 10 5 。
输出格式
对于每组数据输出 1 行。若 a = ∅,则输出 “EMPTY” (不含引号),否则输
出串 a。

输入样例

abababa aa
ccccc a
aaaaa a

输出样例

bbb
ccccc
EMPTY

打表大法好!

/************************************************************************* > File Name: e.cpp > Author: dulun > Mail: [email protected] > Created Time: 2016年04月20日 星期三 14时36分19秒 ************************************************************************/

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;

const int N = 500086;
char m[N], n[N], ans[N];
int h[200];


int main()
{
    while(~scanf("%s%s", m, n))
    {
        memset(h, 0, sizeof(h));
        memset(ans, 0, sizeof(ans));

        int l_n = strlen(n);
        for(int i = 0; i < l_n; i++)
        {
            h[n[i]]++;
        }
        int l_m = strlen(m);
        int cnt = 0;

        for(int i = 0; i < l_m; i++)
        {
            if(h[m[i]] == 0) ans[cnt++] = m[i];
        }
        if(cnt == 0)
        {
            printf("EMPTY\n");
        }
        else{
            printf("%s\n", ans);
        }

    }

    return 0;
}

你可能感兴趣的:(2016西电校赛网络赛 Problem E 删除字符)