csu 1115 最短的名字(字典树)解题报告

1115: 最短的名字

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 771   Solved: 300
[ Submit][ Status][ Web Board]

Description

在一个奇怪的村子中,很多人的名字都很长,比如aaaaa, bbb and abababab。
名字这么长,叫全名显然起来很不方便。所以村民之间一般只叫名字的前缀。比如叫'aaaaa'的时候可以只叫'aaa',因为没有第二个人名字的前三个字母是'aaa'。不过你不能叫'a',因为有两个人的名字都以'a'开头。村里的人都很聪明,他们总是用最短的称呼叫人。输入保证村里不会有一个人的名字是另外一个人名字的前缀(作为推论,任意两个人的名字都不会相同)。
如果村里的某个人要叫所有人的名字(包括他自己),他一共会说多少个字母?

Input

输入第一行为数据组数T (T<=10)。每组数据第一行为一个整数n(1<=n<=1000),即村里的人数。以下n行每行为一个人的名字(仅有小写字母组成)。输入保证一个村里所有人名字的长度之和不超过1,000,000。

Output

对于每组数据,输出所有人名字的字母总数。

Sample Input

1
3
aaaaa
bbb
abababab

Sample Output

5

HINT

Source

湖南省第八届大学生计算机程序设计竞赛


字典树的入门题,可以当模板使用

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <iostream>
using namespace std;

typedef struct zc
{
    int count;
    struct zc *next[26];
}node;
char s[1000010];

node *newnode()
{
    node *q;
    q=(node*)malloc(sizeof(node));
    q->count=1;
    for(int i=0;i<26;i++)
        q->next[i]=NULL;
    return q;
}

void Release(node *T)
{
    for(int i=0;i<26;i++)
        if(T->next[i]!=NULL)
            Release(T->next[i]);
    free(T);
}

void build(node *T,char *s)
{
    node *p;
    p=T;
    int len,k;
    len=strlen(s);
    for(int i=0;i<len;i++)
    {
        k=s[i]-'a';
        if(p->next[k]==NULL)
        {
            p->next[k]=newnode();
            p=p->next[k];
        }
        else
        {
            p=p->next[k];
            p->count++;
        }
    }
}

int search(node *T)
{
    node *q;
    q=T;
    int sum=0;
    for(int i=0;i<26;i++)
    {
        if(T->next[i]!=NULL)
        {
            q=T->next[i];
            sum+=q->count;
            if(q->count>1)
            {
                sum+=search(q);
            }
        }
    }
    return sum;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        node *T;
        T=(node*)malloc(sizeof(node));
        T->count=0;
        for(int i=0;i<26;i++)
            T->next[i]=NULL;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",s);
            build(T,s);
        }
        printf("%d\n",search(T));
        Release(T);
    }
    return 0;
}


你可能感兴趣的:(ACM,字典树)