ZOJ 3822 Domination 概率DP入门

题目描述:

Description
Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What’s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

“That’s interesting!” Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output
For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

题目分析:

概率DP题。题目大意是N*M的方阵,在方格上填石子,求将这个方阵的每行每列都有石子的期望是多少?
用dp[i][j][k]表示用k个石子使i行j列都有石子的概率。
分析:每增加一个石子,有可能出现四种情况,就是
1、这个石子使新的一行新的一列被填。
2、这个石子使新的一行被填。
3、这个石子使新的一列被填。
4、这个石子没有增加行列数。
对这四种情况分别计算对i行j列的被填状况。

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>
const int MAXN =55;

using namespace std;

double dp[MAXN][MAXN][MAXN*MAXN];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int sum=n*m;
        for(int i=0; i<=n; i++)
            for(int j=0; j<=m; j++)
                for(int k=0; k<=sum; k++) dp[i][j][k]=0;
        dp[0][0][0]=1.0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                for(int k=1; k<=sum; k++)
                {
                    dp[i][j][k]+=1.0*dp[i][j][k-1]*(i*j-k+1)/(sum-k+1);
                    //第4种情况
                    dp[i][j][k]+=1.0*dp[i-1][j][k-1]*(n-i+1)*j/(sum-k+1);
                    //第2种情况
                    dp[i][j][k]+=1.0*dp[i][j-1][k-1]*(m-j+1)*i/(sum-k+1);
                    //第3种情况
                    dp[i][j][k]+=1.0*dp[i-1][j-1][k-1]*(n-i+1)*(m-j+1)/(sum-k+1);
                    //第1种情况
                }
            }
        }
        double ans=0.0;
        for(int i=1; i<=sum; i++)
           ans+=(dp[n][m][i]-dp[n][m][i-1])*i;
           //相减是为了除去被重复相加的概率 乘以i是计算期望,期望和就是总期望
        printf("%.12lf\n",ans);
    }
    return 0;
}

你可能感兴趣的:(dp)