杭电Red and Black。。。。水题

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14279    Accepted Submission(s): 8852


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
   
   
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 Sample Output
   
   
   
   
45 59 6 13
 
 
 
#include <iostream>
using namespace std;
char a[22][22];   
int m,n;
int p,q;
int cnt;
void dfs (int x, int y)  
{  
    if (a[x][y]=='#' || x < 1 || x >n|| y < 1 || y > m)  
        return ;  
    ++cnt ;  
    a[x][y] ='#';  
	dfs (x-1, y) ;  
    dfs (x, y-1) ;  
    dfs (x+1, y) ;  
    dfs (x, y+1) ;  
}  
int main ()
{
	
	while(cin>>m>>n)
	{
		int i,j;
		if(m==0&&n==0) break;
		for( i=1;i<=n;i++)
			for( j=1;j<=m;j++)
			{
				cin>>a[i][j];
				if(a[i][j]=='@')
				{
					p=i;
					q=j;
                    a[i][j] = '.' ;  
				}
			}
			
			cnt=0;
			dfs(p,q);
			cout<<cnt<<endl;
	}
	return 0;
}

 
 
 

你可能感兴趣的:(杭电Red and Black。。。。水题)