Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16395 Accepted Submission(s): 6731
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
Source
Asia 2001, Taejon (South Korea)
题意:机器处理木材,每次开始时需要1分钟的设置是时间,如果下一根木棒的长度和重量都大于或等于上一根木棒,呢么就不用去设置,请问怎样设置才能使化肥设置及其的时间最短。
这是刚学贪心算法,按照书上的运行了一遍,弄懂了
思路:将木棒进行自定义排序,长度小,重量轻的排在前边,然后每次从后边的比较,然后算出来最小时间!
代码如下“:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 5005
using namespace std;
struct Node
{
int length,weight;
bool flag; // flag用来标记这根木棒是否处理过
};
bool cmp(Node a,Node b)
{
return a.length<=b.length || (a.length==b.length && a.weight<=b.weight); //自定义排序,长度小,质量轻的排在前边
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
Node node[MAXN];
int n,cot=0,k;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&node[i].length,&node[i].weight);
node[i].flag=false;
}
sort(node,node+n,cmp); //自定义排序,当然有些条件不满足的,可以输出看一下
for(int i=0;i<n;i++)
{
if(node[i].flag) continue; //如果这跟木棒处理过,直接进行下一个循环,知道找到新的未处理的木棒
cot++;k=i; //这时候,花费的时间+1
for(int j=i+1;j<n;j++)
{
if(node[j].length>=node[k].length && node[j].weight>=node[k].weight && node[j].flag==false) // 如果这跟木棒长度,质量都大于上一根而且没有处理过
{
node[j].flag=true; //处理这一跟木棒
k=j;//更新一下,把这一跟作为下一次的对比,看下一根木棒的长度,质量是否满足条件
}
}
}
printf("%d\n",cot);
}
return 0;
}
总结:贪心,每次要看出能贪心的对象,才能去做