UVa 10129 Play on Words 欧拉回路 解题报告

Problem Description

Some of the secret doors contain a very interesting word puzzle.The team of archaeologists has to solve

it to open that doors. Because there is no other way to open thedoors, the puzzle is very important

for us.

There is a large number of magnetic plates on every door. Everyplate has one word written on

it. The plates must be arranged into a sequence in such a way thatevery word begins with the same

letter as the previous word ends. For example, the word ‘acm’ canbe followed by the word ‘motorola’.

Your task is to write a computer program that will read the listof words and determine whether it

is possible to arrange all of the plates in a sequence (accordingto the given rule) and consequently to

open the door.

Input

The input consists of T test cases. The number of them (T) isgiven on the first line of the input file.

Each test case begins with a line containing a single integernumber N that indicates the number of

plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a singleword. Each word

contains at least two and at most 1000 lowercase characters, thatmeans only letters ‘a’ through ‘z’ will

appear in the word. The same word may appear several times in thelist.

Output

Your program has to determine whether it is possible to arrangeall the plates in a sequence such that

the first letter of each word is equal to the last letter of theprevious word. All the plates from the

list must be used, each exactly once. The words mentioned severaltimes must be used that number of

times.

If there exists such an ordering of plates, your program shouldprint the sentence ‘Ordering is

possible.’. Otherwise, output the sentence ‘The door cannot beopened.

Sample Input

3

2

acm

ibm

3

acm

malform

mouse

2

ok

ok

Sample Output

The door cannot be opened.

Ordering is possible.

The door cannot be opened.


分析:首先利用okDeg()判断所有入度等于出度(由于不要求回到原点,则半欧拉图也符合条件),然后用并查集判断是否联通,当两者都满足时,则为欧拉回路。

代码:

#include <cstdio>
#include <cstring>
using namespace std;

#define MAXN 26

int inDeg[MAXN];//入度
int outDeg[MAXN];//出度
int f[MAXN];
int find(int x)
{
    return f[x]==x?x:(f[x]=find(f[x]));
}
void unite(int x, int y)
{
    x = find(x);
    y = find(y);
    if (x != y) f[x] = y;
}
//判断所有点入度=出度,允许有且仅有两个只差一个的,分别当做入口与出口
int okDeg()
{
    int markStar = 0;
    int markEnd = 0;
    for (int i = 0; i < MAXN; i++)
    {
        if (inDeg[i] != outDeg[i])
        {
            if (inDeg[i] + 1 == outDeg[i] && !markStar)
                markStar = 1;
            else if (inDeg[i] == outDeg[i] + 1 && !markEnd)
                markEnd = 1;
            else
                return false;
        }
    }
    return 1;
}

int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        int edge;
        //*c用于处理回车符号
        scanf("%d%*c", &edge);
        memset(inDeg, 0, sizeof(inDeg));
        memset(outDeg, 0, sizeof(outDeg));
        memset(f, 0, sizeof(f));
        for (int i = 0; i < MAXN; i++)
            f[i] = i;
        for (int i = 0; i < edge; i++)
        {
            char str[1005];
            gets(str);
            int u = str[0] - 'a';
            int v = str[strlen(str) - 1] - 'a';
            inDeg[v]++;
            outDeg[u]++;
            unite(u, v);
        }
        if (okDeg())
        {
            int set = 0;
            for (int i = 0; i < MAXN; i++)
                if (inDeg[i]+outDeg[i] != 0 && f[i] == i)
                        set++;
            if (set > 1) printf("The door cannot be opened.\n");
            else printf("Ordering is possible.\n");
        }
        else printf("The door cannot be opened.\n");
    }
    return 0;
}


你可能感兴趣的:(ACM,并查集,欧拉回路)