poj 2081 Recaman's Sequence

Recaman's Sequence
Time Limit: 3000MS   Memory Limit: 60000K
Total Submissions: 22529   Accepted: 9678

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

Source

Shanghai 2004 Preliminary


#include<stdio.h>
#include<string.h>
int  res[500005];
bool vis[3000005];	//res[i]的结果会很大,要开大一点vis[] 
int main(){
	int n;
	memset(vis,true,sizeof(vis));
	res[0]=0;
	for(int i=1;i<=500000;i++){
		int x=res[i-1]-i;
		if(x>0&&vis[x]){ //判断当前值是否是正数并且保证不在res中 
			res[i]=res[i-1]-i;
			vis[x]=false; 
		}
		else {
			res[i]=res[i-1]+i;
			vis[res[i]]=false;
		}
	}
	while(scanf("%d",&n)){
		if(n<0) break;
		printf("%d\n",res[n]);
	}
	return 0;
}





你可能感兴趣的:(poj 2081 Recaman's Sequence)