POJ 3039.Visible Lattice Points【欧拉函数】【4月11】

Visible Lattice Points
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6308   Accepted: 3758

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

POJ 3039.Visible Lattice Points【欧拉函数】【4月11】_第1张图片

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

读明白题意,跟欧拉函数挂钩,不难。打表应该更快

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int C, N;
typedef long long LL;
LL Eular(LL x )//返回x的欧兰函数值
{
    if( x == 0 ) return 0;
    LL res = 1, t = x;
    for(LL i = 2; i <= (LL)sqrt(1.*x); i++)
    {
        if( t%i == 0 )
        {
            res *= (i-1);
            t /= i;
            while( t%i ==0 )
            {
                res *= i;
                t /= i;
            }
        }
        if( t == 1 ) break;
    }
    if( t > 1 ) { res *= (t-1); }
    return res;
}
int main()
{
    scanf("%d", &C);
    for(int kase = 1;kase <= C; ++kase)
    {
        scanf("%d", &N);
        LL sum = 0;
        for(int i = 2;i <= N; ++i)
        {
            sum += 2*Eular((LL)i);
        }
        if(N >= 1) sum += 3;
        cout << kase <<" "<< N <<" "<< sum << endl;
    }
    return 0;
}


你可能感兴趣的:(C++,ACM,poj,欧拉函数)