链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

提示

不得使用数组。

#include<stdio.h>
#include<stdlib.h>
struct nobe
{
    int data;
    struct nobe *next;
}*p,*head,*tail;
int main()
{
    head=(struct nobe* )malloc(sizeof(struct nobe));
    head->next=NULL;
     p=(struct nobe*)malloc(sizeof(struct nobe));
    while(scanf("%d",&p->data),p->data!=-1)
    {
        p->next=head->next;
        head->next=p;
        p=(struct nobe*)malloc(sizeof(struct nobe));
    }
    p=head->next;
    int kk=1;
    while(p)
    {
        if(kk==1)
            kk=0;
        else
            printf(" ");
            printf("%d",p->data);
            p=p->next;
    }
}


你可能感兴趣的:(链表的逆置)