I Hate It

http://acm.hdu.edu.cn/showproblem.php?pid=1754

单点更新求区间最大值

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 58715    Accepted Submission(s): 22875


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
   
   
   
   
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
   
   
   
   
5 6 5 9
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <cmath>
#include <string>
#include <iostream>
#include <string>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
const int SIZE=2e5+10;
using namespace std;
struct sge{
    int Max;
}a[SIZE<<2];
void pushup(int rt){
    a[rt].Max=max(a[rt<<1].Max,a[rt<<1|1].Max);
}
void build(int l,int r,int rt){
    if(l==r){
        scanf("%d",&a[rt].Max);
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int p,int c,int l,int r,int rt){
    if(l==r){
        a[rt].Max=c;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)update(p,c,lson);
    else update(p,c,rson);
    pushup(rt);
}
int query(int L,int R,int l,int r,int rt){
    if(L<=l&&r<=R){
        return a[rt].Max;
    }
    int m=(l+r)>>1;
    int res=0;
    if(L<=m)res=max(res,query(L,R,lson));
    if(R>m)res=max(res,query(L,R,rson));
    return res;
}
int main()
{
    int n,m,x,y;
    char s[5];
    while(scanf("%d%d",&n,&m)!=EOF){
        build(1,n,1);
        for(int i=0;i<m;i++){
            scanf("%s%d%d",s,&x,&y);
            if(s[0]=='U')update(x,y,1,n,1);
            else printf("%d\n",query(x,y,1,n,1));
        }
    }
    return 0;
}


你可能感兴趣的:(I Hate It)