HDU 1856 More is better

 

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 8268    Accepted Submission(s): 3088


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 


 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 


 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 


 

Sample Input
   
   
   
   
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 


 

Sample Output
   
   
   
   
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 


 

Author
lxlcrystal@TJU
 


 

Source
HDU 2007 Programming Contest - Final
 


 

Recommend
lcy

 

继续裸并查集,模板搞起~

#include <stdlib.h> 
#include <iostream>
#include <algorithm>
using namespace std;
const int M = 100005;
int fam[M],member[M];
int cas,n,a,b;

void ufset( )
{
     for( int i=0 ; i<M ; i++ )
          member[i] = 1 , fam[i] = i;     
}

int find( int x )
{
    return x == fam[x] ? x : fam[x] = find( fam[x] );    
}

void merge( int a , int b )
{
     int x,y;
     x = find( a );
     y = find( b );
     if( x!=y ){
         fam[x] = y;
         member[y] += member[x];    
     }     
}

int main()
{
    while( scanf("%d",&n) == 1 ){
           ufset( ); 
           int big = 1;
           for( int i=0 ; i<n ; i++ ){
                scanf("%d%d",&a,&b);
                if( a > big || b >big )
                    big = max(a,b);
                merge( a,b );
           }
           int Max = 0;
           for( int i=1 ; i<=big ; i++ )
                if( member[i] > Max )
                    Max = member[i];
           printf("%d\n",Max);
    }        
    return 0;
}


 

你可能感兴趣的:(HDU 1856 More is better)