HDU 5142 NPY and FFT(水~)

Description
给出一个数n,输出翻转后的n的二进制所表示的数字
Input
第一行为一整数T表示用例组数,每组用例占一行为一整数n(0<=n<=2^31-1)
Output
对于每组用例,输出翻转后的n的二进制所表示的数字
Sample Input
3
6
8
1
Sample Output
3
1
1
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
#define maxn 33
int T,n,res,b[maxn],ans;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        res=ans=0;
        while(n)
        {
            b[res++]=n%2;
            n/=2;
        }
        for(int i=0;i<res;i++)
            if(b[i])ans=2*ans+1;
            else ans*=2;
        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(HDU 5142 NPY and FFT(水~))