A Sweet Journey
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 175 Accepted Submission(s): 87
Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)
Input
In the first line there is an integer t (
1≤t≤50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:
Li,Ri , which represents the interval
[Li,Ri] is swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L .
Make sure intervals are not overlapped which means
Ri<Li+1 for each i (
1≤i<n ).
Others are all flats except the swamps.
Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
Sample Input
Sample Output
题意是,在一个L长的道路上 存在减少能量的的地方存在, 剩余地方都是增加能量的地方
问初始的能量应该为多少,才能使人安全通过.
即在行驶过程中不能使能量和为负数了
Source
2015 ACM/ICPC Asia Regional Shanghai Online
Recommend
hujie | We have carefully selected several similar problems for you: 5478 5476 5475 5474 5473
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int vis[600000];
int main()
{
int T,n,A,B,L,a,b;
while(~scanf("%d",&T))
{
int Case=0;
while(T--)
{
Case++;
scanf("%d%d%d%d",&n,&A,&B,&L);
for(int i=0;i<L;i++)
vis[i]=B;
for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
for(int j=a;j<b;j++)
vis[j]=-A;
}
long long sum=0,Min=0;
//int sum=0;
for(int i=0;i<=L;i++)
{
sum+=vis[i];
// cout<<sum;
// cout<<sum;
if(sum<Min)
Min=sum;
}
//cout<<Min;
printf("Case #%d: ",Case);
printf("%lld\n",0-Min);
}
}
}
S