ZOJ 3323Somali Pirates

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3323


题面:




Somali Pirates Time Limit: 1 Second       Memory Limit: 32768 KB

It is said that the famous Somali Pirates hate digits. So their QQ passwords never contain any digit. Given some lines of candidate passwords, you are asked to delete all the digits in the passwords and print other characters in their original order. So the Somali Pirates can use them as their QQ passwords^^

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains a line indicating a candidate password. The length of the password is between 1 and 20, inclusive. Besides, the password consists of only digits and English letters.

Output

For each candidate password, delete all the digits and print the remaining characters in a line.

Sample Input

2
BeatLA123
1plus1equals1

Sample Output

BeatLA
plusequals


题意:

    把给定的字符串删去数字后输出。

解题:

    是数字跳过,否则输出。


代码:

#include <iostream>
#include <string>
using namespace std;
int main()
{
	int t;
	cin>>t;
	string s;
	while(t--)
	{
		cin>>s;
		for(int i=0;i<s.length();i++)
		if(s[i]>='0'&&s[i]<='9')continue;
		else cout<<s[i];
		cout<<endl;
	}
	return 0;
} 



你可能感兴趣的:(入门,字符串,ZOJ,最水题)