LCS

http://acm.hdu.edu.cn/showproblem.php?pid=1159

生)除了校赛,还有什么途径可以申请加入ACM校队? 

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32449    Accepted Submission(s): 14681


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
       
       
       
       
abcfbc abfcab programming contest abcd mnp
 

Sample Output
       
       
       
       
4 2 0
 

Source
Southeastern Europe 2003
设置状态dp[i][j]表示串s1匹配到i串s2匹配到j时的LCS

转移方程式

if(s1[i]==s2[j])dp[i][j]=dp[i-1][j-1]+1;else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

//dp500-4
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1<<30;
const int SIZE=1e3+10;
char s1[SIZE],s2[SIZE];
int dp[SIZE][SIZE];
int main()
{
    while(scanf("%s%s",s1+1,s2+1)!=EOF){
        int len1=strlen(s1+1),len2=strlen(s2+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=len1;i++)
            for(int j=1;j<=len2;j++){
                if(s1[i]==s2[j])dp[i][j]=dp[i-1][j-1]+1;
                else dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
            }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}


你可能感兴趣的:(LCS)