poj 3624 Charm Bracelet

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


典型的01背包问题;


#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#define pi 3.14159265358979323846
using namespace std;
int weight[40000];
int des[40000];
int ans[40000]={0};
int main()
{
    int N,M;
    scanf("%d %d",&N,&M);
    for(int i=1;i<=N;++i)
    {
        scanf("%d %d",&weight[i],&des[i]);
    }
    //01背包问题的关键	
    for(int i=1;i<=N;++i)
    {
        for(int j=M;j>=weight[i];--j)
        {
            if(ans[j-weight[i]]+des[i]>ans[j])
            {
                ans[j]=ans[j-weight[i]]+des[i];
            }
        }
    }
    printf("%d\n",ans[M]);
    return 0;
}

你可能感兴趣的:(dp,poj)