Code Forces 579 A. Raising Bacteria(位运算)

Description
一个人每天可以往培养皿中放一些细菌,每只细菌每过一天就会变成两只,现在你想得到n只细菌,问最少需要放多少只细菌
Input
一个整数n
Output
输出恰好得到n只细菌最少需要放置多少只细菌
Sample Input
5
Sample Output
2
Solution
简单题,统计n的二进制表示中1的数量即为答案
Code

#include<stdio.h>
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int ans=0;
        while(n)
        {
            if(n%2)ans++;
            n/=2;
        }
        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(Code Forces 579 A. Raising Bacteria(位运算))