用d数组来保存这一条道路中的最小载重量,在不同的道路中要选承载量大的,在同一条道路中要保存这一条路中的最小重量
dijkstra做的
Heavy Transportation
Time Limit: 3000MS |
|
Memory Limit: 30000K |
Total Submissions: 23793 |
|
Accepted: 6317 |
Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
代码如下:
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<cctype>
#include<string>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<sstream>
#include<algorithm>
using namespace std;
const int INF=999999999;
int G[1001][1001];
bool vis[1001];
int d[1001];//从1到i的最大重量道路中的最小重量
int m,n;
int dijkstra()
{
int i,j;
memset(vis,false,sizeof(vis));
for(i=1;i<=n;i++)
d[i]=G[1][i];
vis[1]=true;
d[1]=0;
for(i=2;i<=n;i++)
{
int maxn=-1,w=1;
for(j=1;j<=n;j++)
{
if(!vis[j]&&d[j]>maxn)
{
w=j;
maxn=d[j];
}
}
vis[w]=true;
for(j=1;j<=n;j++)
{
if(vis[j]==false&&G[j][w]!=-1&&d[j]!=-1&&d[w]!=-1)
{
int k=max(d[j],min(d[w],G[w][j]));
d[j]=k;
}
}
}
return d[n];
}
int main()
{
// freopen("D://input.txt", "r", stdin);
int kase=1,kaseto;
scanf("%d",&kaseto);
for(kase=1;kase<=kaseto;kase++)
{
int i,j;
printf("Scenario #%d:\n",kase);
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
G[i][j]=0;
for(i=0;i<m;i++)
{
int s,e,l;
scanf("%d%d%d",&s,&e,&l);
G[s][e]=max(l,G[s][e]);
G[e][s]=G[s][e];
}
printf("%d\n\n",dijkstra());
}
return 0;
}