poj-2955-Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
区间dp,一眼题,但是我在训练中却没有做出来,感觉自己还是太弱。
dp[i][j]代表i->j区间内最多的合法括号数

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

char str[105];
int dp[105][105];

int main()
{
    while(scanf("%s",str)!=EOF)
    {
        if(str[0]=='e')break;
        memset(dp,0,sizeof(dp));
        int l=strlen(str);
        for(int k=1;k<l;k++)
        {
            for(int i=0,j=k;i<l,j<l;j++,i++)
            {
                if(str[i]=='('&&str[j]==')'||str[i]=='['&&str[j]==']')
                    dp[i][j]=dp[i+1][j-1]+2;
                for(int x=i;x<j;x++)
                    dp[i][j]=max(dp[i][j],dp[i][x]+dp[x+1][j]);
            }
        }
        int maxx=0;
        for(int i=0;i<l;i++)
            for(int j=0;j<l;j++)
            if(dp[i][j]>maxx)
            maxx=dp[i][j];
        printf("%d\n",maxx);
    }
    return 0;
}

你可能感兴趣的:(poj-2955-Brackets)