Yet Another Story of Rock-paper-scissors(水题)


Yet Another Story of Rock-paper-scissors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit   Status   Practice   ZOJ 3610

Description

Akihisa and Hideyoshi were lovers. They were sentenced to death by the FFF Inquisition.

 Ryou, the leader of the FFF Inquisition, promised that the winner of Rock-paper-scissors

 would be immune from the punishment. Being lovers, Akihisa and Hideyoshi decided to

 die together with their fists clenched, which indicated rocks in the game. However, at the

 last moment, Akihisa chose paper and Hideyoshi chose scissors. As a result, Akihisa was

 punished by the FFF Inquisition and Hideyoshi survived alone.

When a boy named b and a girl named g are being punished by the FFF Inquisition, they

 will play Rock-paper-scissors and the winner will survive. If there is a tie, then neither

of they will survive. At first, they promise to choose the same gesture x. But actually, the

 boy wants to win and the girl wants to lose. Of course, neither of them knows that the

other one may change his/her gesture. At last, who will survive?

Input

There are multiple test cases. The first line of input is an integer T ≈ 1000

 indicating the number of test cases.

Each test case contains three strings -- bgx. All strings consist of letters

 and their lengths never exceed 20. The gesture x is always one

of"rock", "paper" and "scissors".

Output

If there is a tie, output "Nobody will survive".

Otherwise, output "y will survive" where y is the name of the winner.

Sample Input

1
Akihisa Hideyoshi rock

Sample Output

Hideyoshi will survive

代码:

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;

int main()
{
	int T;
	scanf("%d", &T);
	while(T--) {
		string s1, s2, s3;
		cin >> s1 >> s2 >> s3;
		cout << s2 << " will survive" << endl;
	}
	return 0;
}


你可能感兴趣的:(Yet Another Story of Rock-paper-scissors(水题))