FatMouse's Speed
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13234 Accepted Submission(s): 5827
Special Judge
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that
W[m[1]] < W[m[2]] < ... < W[m[n]]
and
S[m[1]] > S[m[2]] > ... > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
Source
Zhejiang University Training Contest 2001
//这道题实质就是求最长递增子序列的问题,但是需要记录路径。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <stack>
using namespace std;
const int maxn = 1005;
struct Node
{
int w,s,ra;
bool operator < (const Node temp)const //重载小于运算符,将重量小的放在前面
{
if(w != temp.w)
return w < temp.w;
else
return s > temp.s;
}
}node[maxn];
int fa[maxn]; //定义father数组为了找路径上的父节点
int dp[maxn];
int main()
{
int w,s,flag = 1;
while(scanf("%d%d",&w,&s) != EOF)
{
node[flag].ra = flag; //因为sort函数会改变排列顺序,所以需要将原来的编号也保存进结构体
node[flag].w = w;
node[flag++].s = s;
}
sort(node,node+flag);
memset(dp,0,sizeof(dp));
memset(fa,0,sizeof(fa));
int ans = 0,temp;
for(int i = 2; i < flag; i++)
{
if(!dp[i]) dp[i] = 1;
for(int j = i-1; j >= 1; j--)
if(node[j].w != node[i].w && node[j].s > node[i].s && dp[i] < dp[j]+1) //注意判断条件
{
dp[i] = dp[j] + 1;
fa[node[i].ra] = node[j].ra;
}
if(dp[i] > ans)
{
ans = dp[i];
temp = node[i].ra;
}
}
stack <int> S;
S.push(temp);
while(fa[temp]) //因为逆序,所以需要通过栈变为正常顺序
{
S.push(fa[temp]);
temp = fa[temp];
}
printf("%d\n",ans);
while(!S.empty())
{
printf("%d\n",S.top());
S.pop();
}
return 0;
}