POJ 2533 Longest Ordered Subsequence

http://poj.org/problem?id=2533


                                                                                                                          Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 39104   Accepted: 17188

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:求一个严格单调上升子序列的最大长度

解题思路:维护一个单调的队列
新的元素,如果大于队尾元素,即插入队尾
否则二分查找比它大的最小元素,替换掉
最后队列长度即为LIS的解

复杂度分析: 时间复杂度:o(n*logn)
空间复杂度:o(n)


#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=10010;
int a[maxn],b[maxn];
int n;
int w(int *a,int x,int y,int t)
{
  int L=x,R=y,M=0;
  while(L<R)
  {
      M=((R-L)>>1)+L;
      if(a[M]<t) L=M+1;
      else R=M;
  }
  return L;
}
int main()
{
    while(cin>>n && n)
    {
        int t,c=1;
        cin>>b[0];
        for(int i=1;i<n;i++)
        {
            cin>>t;
            if(t>b[c-1]) b[c++]=t;
            else
                b[w(b,0,c,t)]=t;
        }
        cout << c << endl;
    }
    return 0;
}



你可能感兴趣的:(POJ 2533 Longest Ordered Subsequence)