浙大机试2005年HDU 1228 A + B

Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出. 
 

Output
对每个测试用例输出1行,即A+B的值.
 

Sample Input
   
   
   
   
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output
   
   
   
   
3 90 96
 

Source
浙大计算机研究生复试上机考试-2005年



简单字符串

#include <cstdio>
#include <cstring>

using namespace std;

const int maxx = 7;

char trans[10][maxx]={"zero","one","two","three","four","five","six","seven","eight","nine"};

int mytrans(char *str){
    int i;
    int ret = 0;

    for(i=0;i<10;++i){
        if(strcmp(trans[i],str)==0){
            ret = i;
            break;
        }
    }
    return ret;
}
int main(){
    char st[maxx];
    int a,b,c;

    while(true){
        a = 0;
        b = 0;
        while(scanf("%s",st) && strcmp(st,"+")!=0){
            a *= 10;
            a += mytrans(st);
        }
        while(scanf("%s",st) && strcmp(st,"=")!=0){
            b *= 10;
            b += mytrans(st);
        }
        if(a==0 && b==0)break;
        c = a+b;
        printf("%d\n",c);
    }
}



你可能感兴趣的:(字符串,C语言,pat)