分组背包问题,具体详情见背包九讲。、
ACboy needs your help
Time Limit : 1000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9 Accepted Submission(s) : 6
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
Sample Output
#include <iostream>
#include <algorithm>
using namespace std;
int n,m;
int mp[105][105];
int dp[105];
int main()
{
while( scanf("%d%d",&n,&m) == 2 ){
if( n==0 && m==0 )
break;
for( int i=1 ; i<=n ; i++ )
for( int j=1 ; j<=m ; j++ )
scanf("%d",&mp[i][j]);
memset( dp , 0 , sizeof(dp) );
//注意这里的三层循环的顺序 “for v=V..0”这一层循环必须在
//“for 所有的i属于组k”之外。
//这样才能保证每一组内的物品最多只有一个会被添加到背包中。
for( int i=1 ; i<=n ; i++ ){
for( int V=m ; V>=0 ; V-- ){
for( int k=1 ; k<=m ; k++ ){
if( V-k>=0 )
dp[V] = max( dp[V] , dp[V-k]+mp[i][k] );
}
}
}
//for( int i=0 ; i<=m ; i++ )
printf("%d\n",dp[m]);
}
return 0;
}