poj1068

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

题意:

题目意思是p:表示在右括号前左括号的个数

w:表示包括右括号在内的完整括号个数,如()这样的匹配好的

然后稍加理解就能懂,方法因此就比较灵活多变咯

我解题方法就是把左括号看做-1,右括号看做1,然后将它还原成一个数组,然后就可以通过相加为零来判断是否已经匹配好,所有的1相加就是所求答案

#include<stdio.h>

int main()
{
    int a[100];
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int start,temp;
        int pos=1,last=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&temp);
            for(int j=pos;j<pos+temp-last;j++)
                a[j]=-1;
            pos=pos+temp-last;
            a[pos++]=1;
            last=temp;
            if(i==1)
                start=temp;
        }

        last=last*2;
        int ans;
        int tag;
        for(int i=start+1;i<=last;i++){
            if(a[i]==1){
                ans=1;
                tag=1;
                for(int j=i-1;j>0;j--){
                    if(a[j]==1)
                       ans++;

                    tag+=a[j];
                    if(tag==0){
                        printf("%d ",ans);
                        break;
                    }
                }
            }
        }
        puts("");
    }
    return 0;
}

另外网上的答案

#include<stdio.h>


int main()
{
    int a[100];
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int start,temp;
        int pos=1,last=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&temp);
            for(int j=pos;j<pos+temp-last;j++)
                a[j]=-1;
            pos=pos+temp-last;
            a[pos++]=1;
            last=temp;
            if(i==1)
                start=temp;
        }


        last=last*2;
        int ans;
        int tag;
        for(int i=start+1;i<=last;i++){
            if(a[i]==1){
                ans=1;
                tag=1;
                for(int j=i-1;j>0;j--){
                    if(a[j]==1)
                       ans++;


                    tag+=a[j];
                    if(tag==0){
                        printf("%d ",ans);
                        break;
                    }
                }
            }
        }
        puts("");
    }
    return 0;
}

你可能感兴趣的:(poj1068)