数据结构实验之链表四:有序链表的归并

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
输入
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
输出
输出合并后的单链表所包含的M+N个有序的整数。
示例输入
6 5
1 23 26 45 66 99
14 21 28 50 100
示例输出
1 14 21 23 26 28 45 50 66 99 100
题解:建立两个顺序表,注意两个顺序表的输入数据是有序的,合并的过程其实又是建立了一个顺序表。
#include<bits/stdc++.h>
using namespace std;
struct node
{
int data;
struct node *next;
};
struct node *merger(struct node *head1,struct node *q1,struct node *q2)
{
struct node *tail;//归并过程理解其中的建表过程
tail=head1;
while(q1&&q2)
{
if(q1->data<q2->data)
{
tail->next=q1;
tail=q1;
q1=q1->next;
}
else
{
tail->next=q2;
tail=q2;
q2=q2->next;
}
}
if(q1)
tail->next=q1;//假如两个链表中有一个还没到达表尾,就把此时的q1或q2赋给tail->next。
if(q2)
tail->next=q2;
return head1;
};
int main()
{
int x,n,m,i;
cin>>n>>m;
struct node *head1,*tail1,*p1,*q1,*head2,*tail2,*p2,*q2,*p;
head1=new struct node();
head2=new struct node();
head1->next=NULL;
tail1=head1;
p1=new struct node();
head2->next=NULL;
tail2=head2;
p2=new struct node();
for(i=1;i<=n;i++)
{
cin>>x;
p1->data=x;
p1->next=NULL;
tail1->next=p1;
tail1=p1;
p1=new struct node();
}
for(i=1;i<=m;i++)
{
cin>>x;
p2->data=x;
p2->next=NULL;
tail2->next=p2;
tail2=p2;
p2=new struct node();
}
q1=head1->next;
q2=head2->next;
head1->next=NULL;
free(head2);
head1=merger(head1,q1,q2);
for(p=head1->next;p!=NULL;p=p->next)
{
cout<<p->data<<" ";
}
return 0;
}

你可能感兴趣的:(数据结构实验之链表四:有序链表的归并)