浙大PAT 1065. A+B and C (64bit) (20)

1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
主要就是可能会溢出的问题,还有就是a+b只有赋值后才可以检测是否溢出。
溢出只可能发生在两正数相加或者两负数相加时,所以把这两种溢出时的特殊情况拿出来单独考虑就可以了,其他情况是可以直接a+b的

#include <cstdio>

int main(){
	int n,i;
	long long int a,b,c;

	scanf("%d",&n);
	for(i=1;i<=n;++i){
		bool flg = true;
		scanf("%lld %lld %lld",&a,&b,&c);
		long long res = a+b;
		if(a>0 && b>0 && res<=0)flg = true;
		else if(a<0 && b<0 && res>=0)flg = false;
		else{
			if(res<=c)flg = false;
		}
		if(flg){
			printf("Case #%d: true\n",i);
		}else{
			printf("Case #%d: false\n",i);
		}
	}
	return 0;
}



你可能感兴趣的:(pat,机试,浙大)