数据结构实验之链表七:单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n; 
第二行输入n个整数。

输出

第一行输出初始链表元素个数; 
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

提示

 

来源

不得使用数组!
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    struct node *next;
    int data;
};
int main()
{
    struct node *head, *p, *q, *r;
    int n;
    scanf("%d", &n);

    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    for(int i = 0;i < n;i++){
        p = (struct node *)malloc(sizeof(struct node));
        if(i == 0){
            scanf("%d", &p->data);
            p->next = NULL;
            head->next = p;
        }else {
            scanf("%d", &p->data);
            p->next = head->next;
            head->next = p;
        }
    }
    printf("%d\n", n);
    q = head->next;
    while(q != NULL){
        if(q->next != NULL){
            printf("%d ", q->data);
        }else {
            printf("%d", q->data);
        }
        q = q->next;
    }
    printf("\n");

    for(p = head->next;p != NULL;p = p->next){
        for(r = p, q = p->next; q != NULL; q = q->next){
            if(q->data == p->data){
                r->next = q->next;
            }else {
                r = r->next;
            }
        }
    }

    int count = 0;
    for(p = head->next;p != NULL; p = p->next){
        count++;
    }
    printf("%d\n", count);
    q = head->next;
    while(q != NULL){
        if(q->next != NULL){
            printf("%d ", q->data);
        }else {
            printf("%d", q->data);
        }
        q = q->next;
    }
    return 0;
}

你可能感兴趣的:(数据结构实验之链表七:单链表中重复元素的删除)