poj2081 Recaman's Sequence

C - Recaman's Sequence
Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:60000KB     64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 2081
Appoint description: System Crawler (2016-05-11)

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658
打表输出即可。

#include <stdio.h>
#include <string.h>
bool vis[6555550];
int result[500000+5];
int main()
{
	memset(vis,false,sizeof(vis));
	result[0]=0;vis[0]=true;
	for(int i=1;i<=500000;i++)
	{
		int x=result[i-1]-i;
		if(x>0&&!vis[x])
		{
			result[i]=x;
			vis[x]=true;
		}
		else
		{
			result[i]=result[i-1]+i;
			vis[result[i]]=true;
		}
	}
	int n;
	while(~scanf("%d",&n)&&n!=-1)
	{
		printf("%d\n",result[n]);
	}
	return 0;
}



你可能感兴趣的:(poj,2081,poj2081)