Hduoj1879 【并查集】

/*继续畅通工程
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14325    Accepted Submission(s): 6235


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。
现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,
计算出全省畅通需要的最低成本。

 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态
,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
 

Sample Output
3
1
0
 

Author
ZJU
 

Source
浙大计算机研究生复试上机考试-2008年 
*/
#include<stdio.h>
#include<stdlib.h>
struct point
{
	int a, b, cost, statu;
}po[5500];
int mark[110];
int find(int x)
{
	if(x != mark[x])
	{
		mark[x] = find(mark[x]); 
	}
	return mark[x];
}
int merge(int x, int y)
{
	x = find(x);
	y = find(y);
	if(x != y)
	{
		mark[x] = y;
		return 1;
	} 
	return 0;
}
int cmp(const void *a, const void *b)//先对 建设状态进行排序,将已建好的排在前面,未建好的再根据建设费升序排列
{
	struct point *c = (struct point *)a;
	struct point *d = (struct point *)b;
	if(c->statu != d->statu)
	return d->statu - c->statu;
	else
	return c->cost - d->cost; 
}
int main()
{
	int i, j, k, m, n;
	while(scanf("%d", &m) != EOF, m)
	{
		n = m*(m-1) / 2;
		for(i = 1; i <= n; i++)
		scanf("%d%d%d%d", &po[i].a, &po[i].b, &po[i].cost, &po[i].statu);
		qsort(po+1, n, sizeof(po[0]), cmp);
		for(i = 1; i <= m; i++)
		{
			mark[i] = i;
		}
		j = 0;
		for(i = 1; i <= n; i++)
		{
		//	printf("%d%d%d%d  ",po[i].a, po[i].b, po[i].cost, po[i].statu);
			if(merge(po[i].a, po[i].b) && !po[i].statu) // 若果未建好并且在集合内,加上建设费
			j += po[i].cost;
		}
		printf("%d\n", j);
	}
	return 0;
}

你可能感兴趣的:(c)