hdoj 2051 Bitset (进制转换)

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/3    
2768 K (Java/Others
Total Submission(s): 19106    Accepted Submission(s): 14361


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
    
    
    
    
1 2 3
 

Sample Output
    
    
    
    
1 10 11
 

Author
8600 && xhd
 

Source
校庆杯Warm Up
代码:
#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int n;
    int m;
    int a[1010];
    while(~scanf("%d",&n))
    {
        int k=0;
        while(n)
        {
            a[k]=n%2;
            //printf("%d\n",a[k]);
            n/=2;
            k++;
        }
        for(int i=k-1;i>=0;i--)
        {
            printf("%d",a[i]);
        }
        printf("\n");
    }
    return 0;
}




你可能感兴趣的:(hdoj 2051 Bitset (进制转换))