POJ 1477 Box of Bricks

Description

Little Bob likes playing withhis box of bricks. He puts the bricks one upon another and builds stacks ofdifferent height. "Look, I've built a wall!", he tells his oldersister Alice. "Nah, you should make all stacks the same height. Then youwould have a real wall.", she retorts. After a little con- sideration, Bobsees that she is right. So he sets out to rearrange the bricks, one by one, suchthat all stacks are the same height afterwards. But since Bob is lazy he wantsto do this with the minimum number of bricks moved. Can you help?

                             

 

Input

The input consists of severaldata sets. Each set begins with a line containing the number n of stacks Bob hasbuilt. The next line contains n numbers, the heights hi of the n stacks. Youmay assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, itis always possible to rearrange the bricks such that all stacks have the sameheight.

The input is terminated by a set starting with n = 0. This set should not beprocessed.

Output

For each set, first print thenumber of the set, as shown in the sample output. Then print the line "Theminimum number of moves is k.", where k is the minimum number of bricksthat have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input

6

5 2 4 1 7 5

0

Sample Output

Set #1

The minimum number of moves is 5.

 

 大水题

#include<stdio.h>
int main()
{
	int n, i, a[10000], Case = 0, sum, ave, count;
	while(scanf("%d",&n),n)
	{
		Case++;
		for(i = 1,sum = 0;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum += a[i];
		}
		ave = sum / n;
		for(i = 1, count = 0;i<=n;i++)
		{
			if(a[i]>ave)
			{
				count  += (a[i] - ave);
			}
		}
		printf("Set #%d\n",Case);
		printf("The minimum number of moves is %d.\n\n",count);
	}
	return 0;
}


 

你可能感兴趣的:(POJ 1477 Box of Bricks)