HDU-1060-Leftmost Digit

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4

Sample Output

2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

求n^n的第一位数。
令m=n^n,两边同取对数,得到log10(m)=n*log10(n)
再得到,m=10^(n*log10(n))
对于10的整数次幂,第一位是1,所以,第一位数取决于n*log10(n)的小数部分
代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 1000010
using namespace std;
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int n, T;
    long long t;
    double a, b, c;
    cin >> T;
    while(T--)
    {
        cin >> n;
        a = n*log10(n);
        t = (long long)a;
        b = a - t;
        cout <<(long long)pow(10, b) << endl;
    }
    return 0;
}

你可能感兴趣的:(HDU-1060-Leftmost Digit)