HDU 1719 Friend(思维题目)

Friend

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2420 Accepted Submission(s): 1226

Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.

Sample Input
3
13121
12131

Sample Output
YES!
YES!
NO!

思路:首先大家看(a+1)*(b+1)=友好数+1;
其次每个(友好数+1)都是2或者3的倍数,这点可以证明,因为基础的友好数是1和2,那么a=b=1时得到3也是友好数,1和2可以得到5是友好数,然后你往下可以多找几个点,每个友好数可以写成(x+1)=(2^a)*(3^b)的形式,然后往下就好搞了。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            printf("NO!\n");
            continue;
        }
        n++;
        while(n%2==0)
        {
            n=n/2;
        }
        while(n%3==0)
        {
            n=n/3;
        }
        if(n==1)
        {
            printf("YES!\n");
        }
        else
        {
            printf("NO!\n");
        }
    }
    return 0;
}

你可能感兴趣的:(HDU)