HDU 5532 Almost Sorted Array

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 570    Accepted Submission(s): 234


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
   
   
   
   
YES YES NO
 

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)
 
求一遍最长不下降子序列的长度和最长不上升子序列的长度,如果有一个尾n或n-1就是YES否则就是NO。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
#include<fstream>
using namespace std;
int num[100100], le[100100];
int b_search(int l, int r, int x)
{
    int m;
    while(l <= r)
    {
        m = (l + r)>>1;
        if(le[m]<=x)
            l = m + 1;
        else if(le[m]>x)
            r = m - 1;
    }
    return l;
}
int main()
{
    int t, n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i = 1; i<=n; i++)
            scanf("%d", &num[i]);
        if(n<=3)
        {
            puts("YES");
            continue;
        }
        int len = 1;
        le[1] = num[1];
        for(int i = 2; i<=n; i++)
        {
            int k = b_search(1, len, num[i]);
            le[k] = num[i];
            if(k > len)
                len = k;
        }
        int temp = len;
        le[1] = num[n], len = 1;
        for(int i = n-1; i>=1; i--)//反着求一遍就是不上升
        {
            int k = b_search(1, len, num[i]);
            le[k] = num[i];
            if(k > len)
                len = k;
        }
       // cout<<len<< " " << temp << endl;
        if(len == n || temp == n || len == n-1 || temp == n-1)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}


你可能感兴趣的:(HDU 5532 Almost Sorted Array)