HDOJ 1711 Number Sequence(KMP简单模板题)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14793    Accepted Submission(s): 6488


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
   
   
   
   
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
   
   
   
   
6 -1 ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int m,n;
int num1[1000005];
int num2[10005];
int nextn[10005];
void makenext()
{
	int i,j;
	j=-1;
	i=0;
	nextn[i]=j;
	while(i<m)//创建子串next数组 
	{
		if(j==-1||num2[i]==num2[j])
		{
			i++;
			j++;
			nextn[i]=j;
		}
		else
		j=nextn[j];
	}
	return;
}
int kmp()
{
	int i,j;
	i=j=0;
	makenext();
	while(i<n)//一个一个循环 
	{
		if(j==-1||num1[i]==num2[j])
		{
			i++;
			j++;
			if(j==m)
			return i-m+1;
		}
		else
		j=nextn[j];
	}
	return -1;
}
int main()
{
	int t,ans;
	int i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		scanf("%d",&num1[i]);
		for(i=0;i<m;i++)
		scanf("%d",&num2[i]);
		ans=kmp();
		printf("%d\n",ans);
	}
	return 0;
}


 

你可能感兴趣的:(HDOJ 1711 Number Sequence(KMP简单模板题))