HDOJ 2391 Filthy Rich (简单DP)

Filthy Rich

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2512    Accepted Submission(s): 1118


Problem Description
They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.
 

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.
 

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.
 

Sample Input
   
   
   
   
1 3 4 1 10 8 8 0 0 1 8 0 27 0 4
 

Sample Output
   
   
   
   
Scenario #1: 42 题意:求从左上角到右下角的一条路的和的最大值,只能向下或向右 思路:和数塔一样,直接写就好了 总结:最后的输出PE两发= = ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 101000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
int dp[2010][2010];
int main()
{
	int t,n,m,i,j;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
		scanf("%d",&dp[i][j]);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				dp[i][j]=max(dp[i-1][j],dp[i][j-1])+dp[i][j];
			}
		}
		printf("Scenario #%d:\n",++cas);
		printf("%d\n",dp[n][m]);
		printf("\n");
	}
	return 0;
}


你可能感兴趣的:(HDOJ 2391 Filthy Rich (简单DP))