The Famous Clock

The Famous Clock

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

Mr. B, Mr. G and Mr. M are now in Warsaw, Poland, for the 2012’s ACM-ICPC World Finals Contest. They’ve decided to take a 5 hours training every day before the contest. Also, they plan to start training at 10:00 each day since the World Final Contest will do so. The scenery in Warsaw is so attractive that Mr. B would always like to take a walk outside for a while after breakfast. However, Mr. B have to go back before training starts, otherwise his teammates will be annoyed. Here is a problem: Mr. B does not have a watch. In order to know the exact time, he has bought a new watch in Warsaw, but all the numbers on that watch are represented in Roman Numerals. Mr. B cannot understand such kind of numbers. Can you translate for him?

输入
Each test case contains a single line indicating a Roman Numerals that to be translated. All the numbers can be found on clocks. That is, each number in the input represents an integer between 1 and 12. Roman Numerals are expressed by strings consisting of uppercase ‘I’, ‘V’ and ‘X’. See the sample input for further information.
输出
For each test case, display a single line containing a decimal number corresponding to the given Roman Numerals.
样例输入
I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
样例输出
Case 1: 1
Case 2: 2
Case 3: 3
Case 4: 4
Case 5: 5
Case 6: 6
Case 7: 7
Case 8: 8
Case 9: 9
Case 10: 10
Case 11: 11
Case 12: 12
 
     
My programming:
#include <iostream>
#include <string>
using namespace std;
int main()
{
    string strInput;
    int nCount = 1 ;
    while(cin >> strInput)
    {
        if(strInput.compare("I") == 0)
        {
            cout << "Case " << nCount++ << ": 1" << endl;
        }
        else if(strInput.compare("II") == 0)
        {
            cout << "Case " << nCount++ << ": 2" << endl;
        }
        else if(strInput.compare("III") == 0)
        {
            cout << "Case " << nCount++ << ": 3" << endl;
        }
        else if(strInput.compare("IV") == 0)
        {
            cout << "Case " << nCount++ << ": 4" << endl;
        }
        else if(strInput.compare("V") == 0)
        {
            cout << "Case " << nCount++ << ": 5" << endl;
        }
        else if(strInput.compare("VI") == 0)
        {
            cout << "Case " << nCount++ << ": 6" << endl;
        }
        else if(strInput.compare("VII") == 0)
        {
            cout << "Case " << nCount++ << ": 7" << endl;
        }
        else if(strInput.compare("VIII") == 0)
        {
            cout << "Case " << nCount++ << ": 8" << endl;
        }
        else if(strInput.compare("IX") == 0)
        {
            cout << "Case " << nCount++ << ": 9" << endl;
        }
        else if(strInput.compare("X") == 0)
        {
            cout << "Case " << nCount++ << ": 10" << endl;
        }
        else if(strInput.compare("XI") == 0)
        {
            cout << "Case " << nCount++ << ": 11" << endl;
        }
        else if(strInput.compare("XII") == 0)
        {
            cout << "Case " << nCount++ << ": 12" << endl;
        }
    }


    return 0;
}

你可能感兴趣的:(C++,算法,ACM)