HDU1532 - Drainage Ditches(网络流)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13676    Accepted Submission(s): 6467


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
   
   
   
   
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
   
   
   
   
50
 

Source
USACO 93
 


算法经典

将题目意思看懂这道题目便可以解决了

#include <map>
#include <set>
#include <cmath>
#include <ctime>
#include <queue>
#include <vector>
#include <cctype>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;


#define pb push_back
#define mp make_pair
#define fillchar(a, x) memset(a, x, sizeof(a))
#define copy(a, b) memcpy(a, b, sizeof(a))
#define lson rt << 1, l, mid
#define rson rt << 1|1, mid + 1, r


typedef long long LL;
typedef pair<int, int > PII;
typedef unsigned long long uLL;
template<typename T>
void print(T* p, T* q, string Gap = " ") {
    int d = p < q ? 1 : -1;
    while(p != q) {
        cout << *p;
        p += d;
        if(p != q) cout << Gap;
    }
    cout << endl;
}
template<typename T>
void print(const T &a, string bes = "") {
    int len = bes.length();
    if(len >= 2)cout << bes[0] << a << bes[1] << endl;
    else cout << a << endl;
}

const int INF = 0x3f3f3f3f;
const int MAXM = 2e5;
const int MAXN = 200 + 5;
int N, M;
struct edge {
    int to, cap, rev;
};
vector<edge> G[MAXN];
bool vis[MAXN];

void add_edge(int from, int to,int cap) {
    G[from].push_back((edge) {
        to, cap, G[to].size()
    });
    G[to].push_back((edge) {
        from, 0, G[from].size() - 1
    });
}

int DFS(int v, int t, int f) {
    if(v == t) return f;
    vis[v] = true;
    for(int i = 0; i < G[v].size(); i ++) {
        edge &e = G[v][i];
        if(!vis[e.to] && e.cap > 0) {
            int d = DFS(e.to, t, min(f, e.cap));
            if(d > 0) {
                e.cap -= d;
                G[e.to][e.rev].cap += d;
                return d;
            }
        }
    }
    return 0;
}

LL max_flow(int s, int t) {
    LL flow = 0;
    for(;;) {
        memset(vis, false, sizeof(vis));
        int f = DFS(s, t, INF);
        if(f == 0) return flow;
        flow += f;
    }
}

int main() {
    int s, e, c;
    while(~scanf("%d%d", &N, &M)) {
        for(int i = 0;i <= M;i ++) G[i].clear();
        for(int i = 0;i < N;i ++){
            scanf("%d%d%d", &s, &e, &c);
            add_edge(s, e, c);
        }
        printf("%lld\n", max_flow(1, M));
    }
    return 0;
}


你可能感兴趣的:(HDU1532 - Drainage Ditches(网络流))