BNU 16485 Build The Electric System

Build The Electric System

Time Limit: 2000ms
Memory Limit: 65536KB
This problem will be judged on ZJU. Original ID:  2966
64-bit integer IO format:  %lld      Java class name:  Main
Prev  Submit  Status  Statistics  Discuss  Next
Font Size:  +   -

In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and lots of villages lost contact with the main power grid. The government wants to reconstruct the electric system as soon as possible. So, as a professional programmer, you are asked to write a program to calculate the minimum cost to reconstruct the power lines to make sure there's at least one way between every two villages.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

In each test case, the first line contains two positive integers N and E (2 <= N <= 500, N <= E <= N * (N - 1) / 2), representing the number of the villages and the number of the original power lines between villages. There follow E lines, and each of them contains three integers, ABK (0 <= AB < N, 0 <= K < 1000). A andB respectively means the index of the starting village and ending village of the power line. If K is 0, it means this line still works fine after the snow storm. If K is a positive integer, it means this line will cost K to reconstruct. There will be at most one line between any two villages, and there will not be any line from one village to itself.

Output

For each test case in the input, there's only one line that contains the minimum cost to recover the electric system to make sure that there's at least one way between every two villages.

Sample Input

1
3 3
0 1 5
0 2 0
1 2 9

Sample Output

5

Source

The 5th Zhejiang Provincial Collegiate Programming Contest

Author

ZHOU, Ran

题意:n个村庄 e条线路 k是线路的修理费用 问最少要多少钱才能恢复这些村庄的供电
思路:先对e条线进行 排序 把修理费用少的放在前面
然后用并查一下看哪几个是联通的 就不用修了
再把不同的修好 联通起来就ok了

#include<stdio.h>
#include<algorithm>
using namespace std;
int father[50000];
int find(int x)
{
    return father[x]==x?father[x]:find(father[x]);
}
struct ml
{
    int a,b,k;
}p[50000];
int cmp(ml x,ml y)
{
    return x.k<y.k;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,e;
        scanf("%d%d",&n,&e);

        for(int i=0;i<e;i++)
            scanf("%d%d%d",&p[i].a,&p[i].b,&p[i].k);
        sort(p,p+e,cmp);

        for(int i=0;i<n;i++)
            father[i]=i;
        int sum=0;

        for(int i=0;i<e;i++)
        {
            int fx=find(p[i].a);
            int fy=find(p[i].b);
            if(fx!=fy)
            {
                father[fx]=fy;
                sum+=p[i].k;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


你可能感兴趣的:(图形,BNU)