hduoj1398!【母函数】

/*Square Coins
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8175    Accepted Submission(s): 5550

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square
 numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.


Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all
 the amounts are positive and less than 300.

 
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other
 characters should appear in the output. 

 
Sample Input
2
10
30
0
 
Sample Output
1
4
27
 
Source
Asia 1999, Kyoto (Japan) 
*/
#include<stdio.h>
#include<string.h>
int main()
{
	__int64 a[500], b[500], i, j, k, n;
	for(i = 0; i < 500; i++)
	a[i] = 1;
	for(i = 2; i <= 17; i++)
	{
		memset(b, 0 ,sizeof(b));
		for( j = 0 ; j <= 500; j++)
		for(k = 0; k + j <= 500; k += i*i)
		b[k+j] += a[j];
		for(j = 0; j < 500; j++)
		a[j] = b[j];
	}
	while( scanf("%I64d", &n) != EOF && n)
	printf("%I64d\n", a[n]);
	return 0;
}	


题意:用1 ~17 各个数的平方的数来计算所能付款某个数的情况数。

典型的母函数,唯一不同的是基数不是1~n递增的,而是1~17每个数的平方。

第一次用母函数,算是小懂了。

你可能感兴趣的:(c)